Degraded performance
Resolved·Degraded performance

Today, we experienced a slowdown in our servers due to a combination of increased data volume from our new financial numbers and a misconfiguration in our database infrastructure. This caused response times to become unacceptably high.

We resolved the incident by updating our database configuration to better handle unexpected traffic spikes. We also updated our monitoring to ensure similar issues are detected earlier.

Tue, Nov 25, 2025, 12:19 PM
(2 weeks ago)
·
Affected components
Operating
API
Updates

Resolved

Today, we experienced a slowdown in our servers due to a combination of increased data volume from our new financial numbers and a misconfiguration in our database infrastructure. This caused response times to become unacceptably high.

We resolved the incident by updating our database configuration to better handle unexpected traffic spikes. We also updated our monitoring to ensure similar issues are detected earlier.

Tue, Nov 25, 2025, 12:19 PM

Monitoring

The issue is now fixed. We will continue to closely monitor service status until we're sure the issue is resolved.

Tue, Nov 25, 2025, 10:42 AM(1 hour earlier)

Identified

Operating platform is slower than usual. We have identified the source of the issue and are working towards a solution.

Tue, Nov 25, 2025, 09:31 AM(1 hour earlier)